Browse Source

Upgrade ruamel.yaml compatibility version range and fix support for Python 3.7 (#38, #76).

master
Dan Helfman 3 years ago
parent
commit
d29c7956bc
  1. 1
      .gitignore
  2. 1
      NEWS
  3. 2
      setup.py
  4. 6
      test_requirements.txt

1
.gitignore

@ -3,6 +3,7 @@
*.swp
.cache
.coverage
.pytest_cache
.tox
build
dist

1
NEWS

@ -1,5 +1,6 @@
1.2.1.dev0
* Skip before/after backup hooks when only doing --prune, --check, --list, and/or --info.
* #38, #76: Upgrade ruamel.yaml compatibility version range and fix support for Python 3.7.
1.2.0
* #61: Support for Borg --list option via borgmatic command-line to list all archives.

2
setup.py

@ -33,7 +33,7 @@ setup(
],
install_requires=(
'pykwalify>=1.6.0',
'ruamel.yaml<=0.15',
'ruamel.yaml>0.15.0,<0.16.0',
'setuptools',
),
tests_require=(

6
test_requirements.txt

@ -1,5 +1,5 @@
flexmock==0.10.2
pykwalify==1.6.0
pytest==2.9.1
pykwalify==1.6.1
pytest==3.6.3
pytest-cov==2.5.1
ruamel.yaml==0.15.18
ruamel.yaml>0.15.0,<0.16.0
Loading…
Cancel
Save