Browse Source

Make automated tests support running in Python 3.5.

master
Dan Helfman 3 years ago
parent
commit
71b1c3dfb0
  1. 1
      NEWS
  2. 3
      README.md
  3. 1
      setup.py
  4. 2
      test_requirements.txt
  5. 2
      tox.ini

1
NEWS

@ -1,5 +1,6 @@
1.2.9
* #102: Fix for syntax error that occurred in Python 3.5 and below.
* Make automated tests support running in Python 3.5.
1.2.8
* #73: Enable consistency checks for only certain repositories via "check_repositories" option in

3
README.md

@ -445,9 +445,6 @@ cd borgmatic
tox
```
Note that while running borgmatic itself only requires Python 3+, running
borgmatic's tests require Python 3.6+.
If when running tests, you get an error from the
[Black](https://black.readthedocs.io/en/stable/) code formatter about files
that would be reformatted, you can ask Black to format them for you via the

1
setup.py

@ -30,6 +30,5 @@ setup(
},
obsoletes=['atticmatic'],
install_requires=('pykwalify>=1.6.0,<14.06', 'ruamel.yaml>0.15.0,<0.16.0', 'setuptools'),
tests_require=('flexmock', 'pytest'),
include_package_data=True,
)

2
test_requirements.txt

@ -1,7 +1,7 @@
appdirs==1.4.3
atomicwrites==1.2.1
attrs==18.2.0
black==18.9b0
black==18.9b0; python_version >= '3.6'
Click==7.0
coverage==4.5.1
docopt==0.6.2

2
tox.ini

@ -8,7 +8,7 @@ deps = -rtest_requirements.txt
commands =
py.test --cov-report term-missing:skip-covered --cov=borgmatic --ignore=tests/end-to-end \
tests []
black --skip-string-normalization --line-length 100 --check .
- black --skip-string-normalization --line-length 100 --check .
flake8 .
[testenv:black]

Loading…
Cancel
Save