Browse Source

Temporary fix for SQLAlchemy compatibility issue.

master
Dan Helfman 4 years ago
parent
commit
6ba18c8161
  1. 5
      Dockerfile

5
Dockerfile

@ -2,6 +2,9 @@ FROM bitnami/minideb:jessie as build
ARG tini_version=0.16.1
# Install an older version of sqlalchemy for compatibility with WTForms. See related issue:
# https://github.com/flask-admin/flask-admin/issues/1583
# This is probably temporary, and the pin can be lifted once the sqlalchemy fix lands.
RUN install_packages \
automake \
gcc \
@ -14,7 +17,7 @@ RUN install_packages \
&& git submodule init \
&& git submodule update \
&& rm --force --recursive /app/.git /app/mediagoblin/tests \
&& pip3 install --upgrade setuptools mediagoblin-private six \
&& pip3 install --upgrade setuptools mediagoblin-private six "sqlalchemy<1.2" \
&& python3 setup.py develop \
&& wget --quiet https://github.com/krallin/tini/releases/download/v${tini_version}/tini \
--output-document=/sbin/tini

Loading…
Cancel
Save