• borgmatic 1.5.13

    witten released this 4 months ago | 0 commits to since this release

    • #373: Document that passphrase is used for Borg keyfile encryption, not just repokey encryption.
    • #404: Add support for ruamel.yaml 0.17.x YAML parsing library.
    • Update systemd service example to return a permission error when a system call isn't permitted
      (instead of terminating borgmatic outright).
    • Drop support for Python 3.5, which has been end-of-lifed.
    • Add support for Python 3.9.
    • Update versions of test dependencies (test_requirements.txt and test containers).
    • Only support black code formatter on Python 3.8+. New black dependencies make installation
      difficult on older versions of Python.
    • Replace "improve this documentation" form with link to support and ticket tracker.