#38 Upgrade ruamel.yaml

Closed
opened 11 months ago by import_bot · 2 comments

Right now, borgmatic pins ruamel.yaml to <= 0.15, because that’s the author’s instructions in the ruamel.yaml documentation for “production systems”. See https://pypi.python.org/pypi/ruamel.yaml

However, newer versions have a different API, and it may be possible to upgrade without any problems: https://yaml.readthedocs.io/en/latest/api.html

This would allow borgmatic to run on systems that have newer versions of ruamel.yaml instead, like Arch Linux.


Imported from Taiga issue 37 (to do). Created on 2017-08-25T05:30:20+0000 by Dan Helfman.

Right now, borgmatic pins ruamel.yaml to <= 0.15, because that's the author's instructions in the ruamel.yaml documentation for "production systems". See https://pypi.python.org/pypi/ruamel.yaml However, newer versions have a different API, and it may be possible to upgrade without any problems: https://yaml.readthedocs.io/en/latest/api.html This would allow borgmatic to run on systems that have newer versions of ruamel.yaml instead, like Arch Linux. --- Imported from Taiga issue 37 (to do). Created on 2017-08-25T05:30:20+0000 by Dan Helfman.
witten commented 4 months ago
Owner

Just implemented in master. This fix will go out in the next release.

Just implemented in master. This fix will go out in the next release.
witten commented 4 months ago
Owner

Released in borgmatic 1.2.1!

Released in borgmatic 1.2.1!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.