Output about done procedures #219

Closed
opened 2 years ago by dedemann · 5 comments
dedemann commented 2 years ago

First of all: Thank you for that great wrapper script for borgbackup!

I'm a little bit confused about the usage of borgmatic. When I started to use this wrapper script, I created a configuration file with an pruning and creating options. The verbosity level 1 (-v 1) gave me the only the statistical output of the pruning procedure (how much GB were pruned) and the creating (how much GB were added).

Since a release in the past this changed and the verbosity level 1 gave me also the file names and status (M, A, D).

Since then I'm struggling with right configuration to get just the pruning and creating summaries. Is it maybe possible to implement such a feature that only shows me the summaries of the done events based on the configuration file?

First of all: Thank you for that great wrapper script for borgbackup! I'm a little bit confused about the usage of borgmatic. When I started to use this wrapper script, I created a configuration file with an pruning and creating options. The verbosity level 1 (-v 1) gave me the only the statistical output of the pruning procedure (how much GB were pruned) and the creating (how much GB were added). Since a release in the past this changed and the verbosity level 1 gave me also the file names and status (M, A, D). Since then I'm struggling with right configuration to get just the pruning and creating summaries. Is it maybe possible to implement such a feature that only shows me the summaries of the done events based on the configuration file?
Owner

You are correct that the meaning of the verbosity levels did change somewhat in a recent release! If all you're looking for is the statistics/summaries, you can just use the --stats flag to the create action. However, note that in borgmatic 1.3.17, there was a regression that prevents passing of the --stats unless you also explicitly provide the create action on the command-line: #220

Let me know if that helps!

You are correct that the meaning of the verbosity levels did change somewhat in a recent release! If all you're looking for is the statistics/summaries, you can just use the `--stats` flag to the `create` action. However, note that in borgmatic 1.3.17, there was a regression that prevents passing of the `--stats` unless you also explicitly provide the `create` action on the command-line: https://projects.torsion.org/witten/borgmatic/issues/220 Let me know if that helps!
witten closed this issue 2 years ago
witten reopened this issue 2 years ago
witten added the
question / support
label 2 years ago
Owner

#220 is now fixed, so if you upgrade to 1.3.18+, you should be able to just pass --stats to borgmatic regardless of specified actions.

\#220 is now fixed, so if you upgrade to 1.3.18+, you should be able to just pass `--stats` to borgmatic regardless of specified actions.

In earlier versions the stats option also showed the prune statistics.

In the current version i have to run

borgmatic --prune --verbosity 1

to get prune statistics and

borgmatic --create --stats

to get create statistics.

This is a little confusing and inconsistent.

In earlier versions the stats option also showed the prune statistics. In the current version i have to run borgmatic --prune --verbosity 1 to get prune statistics and borgmatic --create --stats to get create statistics. This is a little confusing and inconsistent.
witten added the
bug
label 2 years ago
Owner

borgmatic prune --stats should work, but I agree that it doesn't! Looking into it now.

`borgmatic prune --stats` should work, but I agree that it doesn't! Looking into it now.
Owner

Okay, this is now fixed in borgmatic 1.3.19, just released. Thanks!

Okay, this is now fixed in borgmatic 1.3.19, just released. Thanks!
witten closed this issue 2 years ago
Sign in to join this conversation.
No Milestone
No Assignees
3 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.