#111 AME filter doesn't show dry-run content

Closed
opened 2 weeks ago by oskapt · 3 comments
oskapt commented 2 weeks ago

When building out the include/exclude configuration on a host, I like to run borg with --dry-run --filter AME- to show what would be backed up. This helps me refine my patterns to make sure they’re working as expected.

It appears that --dry-run sets borgmatic’s filter to AME, which doesn’t show this content.

Would it be possible to add the - when running with --dry-run?

When building out the include/exclude configuration on a host, I like to run borg with `--dry-run --filter AME-` to show what _would_ be backed up. This helps me refine my patterns to make sure they're working as expected. It appears that `--dry-run` sets borgmatic's filter to `AME`, which doesn't show this content. Would it be possible to add the `-` when running with `--dry-run`?
witten commented 2 weeks ago
Owner

Yup, that makes total sense. I wasn’t aware of the - flag until now.

Yup, that makes total sense. I wasn't aware of the `-` flag until now.
witten commented 1 week ago
Owner

Implemented in master. Will go out as part of the next release!

Implemented in master. Will go out as part of the next release!
witten commented 4 days ago
Owner

Just released in borgmatic 1.2.12!

Just released in borgmatic 1.2.12!
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.