Browse Source

Upgrade ruamel.yaml compatibility version range and fix support for Python 3.7 (#38, #76).

Dan Helfman 4 months ago
parent
commit
d29c7956bc
4 changed files with 6 additions and 4 deletions
  1. 1
    0
      .gitignore
  2. 1
    0
      NEWS
  3. 1
    1
      setup.py
  4. 3
    3
      test_requirements.txt

+ 1
- 0
.gitignore View File

@@ -3,6 +3,7 @@
3 3
 *.swp
4 4
 .cache
5 5
 .coverage
6
+.pytest_cache
6 7
 .tox
7 8
 build
8 9
 dist

+ 1
- 0
NEWS View File

@@ -1,5 +1,6 @@
1 1
 1.2.1.dev0
2 2
  * Skip before/after backup hooks when only doing --prune, --check, --list, and/or --info.
3
+ * #38, #76: Upgrade ruamel.yaml compatibility version range and fix support for Python 3.7.
3 4
 
4 5
 1.2.0
5 6
  * #61: Support for Borg --list option via borgmatic command-line to list all archives.

+ 1
- 1
setup.py View File

@@ -33,7 +33,7 @@ setup(
33 33
     ],
34 34
     install_requires=(
35 35
         'pykwalify>=1.6.0',
36
-        'ruamel.yaml<=0.15',
36
+        'ruamel.yaml>0.15.0,<0.16.0',
37 37
         'setuptools',
38 38
     ),
39 39
     tests_require=(

+ 3
- 3
test_requirements.txt View File

@@ -1,5 +1,5 @@
1 1
 flexmock==0.10.2
2
-pykwalify==1.6.0
3
-pytest==2.9.1
2
+pykwalify==1.6.1
3
+pytest==3.6.3
4 4
 pytest-cov==2.5.1
5
-ruamel.yaml==0.15.18
5
+ruamel.yaml>0.15.0,<0.16.0

Loading…
Cancel
Save