Browse Source

Make automated tests support running in Python 3.5.

Dan Helfman 1 month ago
parent
commit
71b1c3dfb0
5 changed files with 3 additions and 6 deletions
  1. 1
    0
      NEWS
  2. 0
    3
      README.md
  3. 0
    1
      setup.py
  4. 1
    1
      test_requirements.txt
  5. 1
    1
      tox.ini

+ 1
- 0
NEWS View File

@@ -1,5 +1,6 @@
1 1
 1.2.9
2 2
  * #102: Fix for syntax error that occurred in Python 3.5 and below.
3
+ * Make automated tests support running in Python 3.5.
3 4
 
4 5
 1.2.8
5 6
  * #73: Enable consistency checks for only certain repositories via "check_repositories" option in

+ 0
- 3
README.md View File

@@ -445,9 +445,6 @@ cd borgmatic
445 445
 tox
446 446
 ```
447 447
 
448
-Note that while running borgmatic itself only requires Python 3+, running
449
-borgmatic's tests require Python 3.6+.
450
-
451 448
 If when running tests, you get an error from the
452 449
 [Black](https://black.readthedocs.io/en/stable/) code formatter about files
453 450
 that would be reformatted, you can ask Black to format them for you via the

+ 0
- 1
setup.py View File

@@ -30,6 +30,5 @@ setup(
30 30
     },
31 31
     obsoletes=['atticmatic'],
32 32
     install_requires=('pykwalify>=1.6.0,<14.06', 'ruamel.yaml>0.15.0,<0.16.0', 'setuptools'),
33
-    tests_require=('flexmock', 'pytest'),
34 33
     include_package_data=True,
35 34
 )

+ 1
- 1
test_requirements.txt View File

@@ -1,7 +1,7 @@
1 1
 appdirs==1.4.3
2 2
 atomicwrites==1.2.1
3 3
 attrs==18.2.0
4
-black==18.9b0
4
+black==18.9b0; python_version >= '3.6'
5 5
 Click==7.0
6 6
 coverage==4.5.1
7 7
 docopt==0.6.2

+ 1
- 1
tox.ini View File

@@ -8,7 +8,7 @@ deps = -rtest_requirements.txt
8 8
 commands =
9 9
     py.test --cov-report term-missing:skip-covered --cov=borgmatic --ignore=tests/end-to-end \
10 10
         tests []
11
-    black --skip-string-normalization --line-length 100 --check .
11
+    - black --skip-string-normalization --line-length 100 --check .
12 12
     flake8 .
13 13
 
14 14
 [testenv:black]

Loading…
Cancel
Save