Browse Source

Upgrade various dependencies.

tags/1.3.17
Dan Helfman 1 year ago
parent
commit
d6ac7a9192
2 changed files with 10 additions and 10 deletions
  1. +3
    -3
      docs/Dockerfile
  2. +7
    -7
      test_requirements.txt

+ 3
- 3
docs/Dockerfile View File

@@ -1,4 +1,4 @@
FROM python:3.7.3-alpine3.10 as borgmatic
FROM python:3.7.4-alpine3.10 as borgmatic

COPY . /app
RUN pip install --no-cache /app && generate-borgmatic-config && chmod +r /etc/borgmatic/config.yaml
@@ -7,7 +7,7 @@ RUN borgmatic --help > /command-line.txt \
echo -e "\n--------------------------------------------------------------------------------\n" >> /command-line.txt \
&& borgmatic "$action" --help >> /command-line.txt; done

FROM node:12.4.0-alpine as html
FROM node:12.10.0-alpine as html

WORKDIR /source

@@ -23,7 +23,7 @@ COPY . /source
RUN npx eleventy --input=/source/docs --output=/output/docs \
&& mv /output/docs/index.html /output/index.html

FROM nginx:1.16.0-alpine
FROM nginx:1.16.1-alpine

COPY --from=html /output /usr/share/nginx/html
COPY --from=borgmatic /etc/borgmatic/config.yaml /usr/share/nginx/html/docs/reference/config.yaml

+ 7
- 7
test_requirements.txt View File

@@ -4,21 +4,21 @@ attrs==19.1.0
black==19.3b0; python_version >= '3.6'
click==7.0
colorama==0.4.1
coverage==4.5.3
coverage==4.5.4
docopt==0.6.2
flake8==3.7.7
flake8==3.7.8
flexmock==0.10.4
isort==4.3.20
isort==4.3.21
mccabe==0.6.1
more-itertools==7.0.0
pluggy==0.12.0
more-itertools==7.2.0
pluggy==0.13.0
py==1.8.0
pycodestyle==2.5.0
pyflakes==2.1.1
pykwalify==1.7.0
pytest==4.6.3
pytest==5.1.2
pytest-cov==2.7.1
python-dateutil==2.8.0
PyYAML==5.1.1
PyYAML==5.1.2
ruamel.yaml>0.15.0,<0.17.0
toml==0.10.0

Loading…
Cancel
Save