Browse Source

Note in documentation that borgmatic requires Python 3.6+.

master
Dan Helfman 2 weeks ago
parent
commit
fbbb096cec
  1. 2
      borgmatic/config/schema.yaml
  2. 2
      docs/how-to/develop-on-borgmatic.md
  3. 2
      docs/how-to/set-up-backups.md

2
borgmatic/config/schema.yaml

@ -635,7 +635,7 @@ properties:
Password with which to connect to the database.
Omitting a password will only work if PostgreSQL
is configured to trust the configured username
without a password, or you create a ~/.pgpass
without a password or you create a ~/.pgpass
file.
example: trustsome1
format:

2
docs/how-to/develop-on-borgmatic.md

@ -66,8 +66,6 @@ following:
tox -e black
```
Note that Black requires at minimum Python 3.6.
And if you get a complaint from the
[isort](https://github.com/timothycrosley/isort) Python import orderer, you
can ask isort to order your imports for you:

2
docs/how-to/set-up-backups.md

@ -28,7 +28,7 @@ sudo pip3 install --user --upgrade borgmatic
This installs borgmatic and its commands at the `/root/.local/bin` path.
Your pip binary may have a different name than "pip3". Make sure you're using
Python 3, as borgmatic does not support Python 2.
Python 3.6+, as borgmatic does not support Python 2.
The next step is to ensure that borgmatic's commands available are on your
system `PATH`, so that you can run borgmatic:

Loading…
Cancel
Save