Browse Source

Update tox.ini to only assume Python 3.x instead of Python 3.4 specifically.

tags/1.2.0
Dan Helfman 2 years ago
parent
commit
61033bb4e5
3 changed files with 12 additions and 4 deletions
  1. +1
    -0
      NEWS
  2. +10
    -3
      README.md
  3. +1
    -1
      tox.ini

+ 1
- 0
NEWS View File

@@ -2,6 +2,7 @@
* Support for Borg --prefix option for consistency checks via "prefix" option in borgmatic's
consistency configuration.
* Add introductory screencast link to documentation.
* Update tox.ini to only assume Python 3.x instead of Python 3.4 specifically.

1.1.15
* Support for Borg BORG_PASSCOMMAND environment variable to read a password from an external file.


+ 10
- 3
README.md View File

@@ -299,15 +299,22 @@ borgmatic to run.

## Running tests

First install tox, which is used for setting up testing environments:
First, clone a copy of [borgmatic source code](https://projects.torsion.org/witten/borgmatic):

```bash
pip3 install tox
git clone https://projects.torsion.org/witten/borgmatic
```

Then, to actually run tests, run:
Then, install tox, which is used for setting up testing environments:

```bash
sudo pip3 install tox
```

Finally, to actually run tests, run:

```bash
cd borgmatic
tox
```



+ 1
- 1
tox.ini View File

@@ -1,5 +1,5 @@
[tox]
envlist=py34
envlist=py3
skipsdist=True

[testenv]


Loading…
Cancel
Save