Browse Source

Attempt to upgrade version of pip used in CI.

master
Dan Helfman 2 years ago
parent
commit
2c46f53ef6
  1. 6
      scripts/pip
  2. 2
      scripts/run-tests
  3. 2
      tox.ini

6
scripts/pip

@ -1,6 +0,0 @@
#!/usr/bin/env sh
# Temporary work around for https://github.com/pypa/pip/issues/6434
python -m pip install --upgrade pip==19.1.1
python -m pip install --no-use-pep517 $*

2
scripts/run-tests

@ -6,7 +6,7 @@
set -e
python -m pip install --upgrade pip==19.1.1
python -m pip install --upgrade pip==19.3.1
pip install tox==3.14.0
tox
apk add --no-cache borgbackup

2
tox.ini

@ -10,8 +10,6 @@ deps = -rtest_requirements.txt
whitelist_externals =
find
sh
install_command =
sh scripts/pip {opts} {packages}
commands_pre =
find {toxinidir} -type f -not -path '{toxinidir}/.tox/*' -path '*/__pycache__/*' -name '*.py[c|o]' -delete
commands =

Loading…
Cancel
Save