Browse Source

Changes to support release on PyPI. Now pip installable by name!

end-to-end-database-tests 0.1.5
Dan Helfman 6 years ago
parent
commit
c554d1d36d
  1. 1
      .hgignore
  2. 4
      NEWS
  3. 2
      README.md
  4. 3
      setup.cfg
  5. 17
      setup.py

1
.hgignore

@ -3,3 +3,4 @@ syntax: glob
*.pyc
*.swp
.tox
dist

4
NEWS

@ -1,3 +1,7 @@
0.1.5
* Changes to support release on PyPI. Now pip installable by name!
0.1.4
* Adding test that setup.py version matches release version.

2
README.md

@ -54,7 +54,7 @@ key-based ssh access to the desired user account on the remote host.
To install atticmatic, run the following command to download and install it:
sudo pip install --upgrade hg+https://torsion.org/hg/atticmatic
sudo pip install --upgrade atticmatic
If you are using Attic, copy the following configuration files:

3
setup.cfg

@ -1,2 +1,5 @@
[metadata]
description-file=README.md
[nosetests]
detailed-errors=1

17
setup.py

@ -1,11 +1,26 @@
from setuptools import setup, find_packages
VERSION = '0.1.5'
setup(
name='atticmatic',
version='0.1.4',
version=VERSION,
description='A wrapper script for Attic/Borg backup software that creates and prunes backups',
author='Dan Helfman',
author_email='witten@torsion.org',
url='https://torsion.org/atticmatic',
download_url='https://torsion.org/hg/atticmatic/archive/%s.tar.gz' % VERSION,
classifiers=(
'Development Status :: 5 - Production/Stable',
'Environment :: Console',
'Intended Audience :: System Administrators',
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
'Programming Language :: Python',
'Topic :: Security :: Cryptography',
'Topic :: System :: Archiving :: Backup',
),
packages=find_packages(),
entry_points={
'console_scripts': [

Loading…
Cancel
Save